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In Chapter 1, you learned basic database con-
cepts. This chapter, on the other hand, is
specific to Access (now called Microsoft Office
Access).

Some caveats are in order. Unless you’ve previ-
ously used another high-end table-based
database, you’ll find Access to be a difficult
program to learn and use. Unlike the other
main applications in Microsoft Office (Word,
Excel, PowerPoint, and Outlook), Access is not
a program that is immediately obvious and
understandable.

Before starting this book, I leafed through half
a dozen elementary books on Access and dis-
covered a commonality among them. Not one
provided a comprehensive overview of the
program or its terminology. Thus, my intent in
this chapter is to start you off right by showing
you The Big Picture—how Access works, how
its many components fit together, and how
you will eventually use them to create, modify,
and enter data in databases. Once you see how
the pieces of this software puzzle fit together,
it is my hope that the more specific material
presented in later chapters won’t confuse you.

Excerpted from Microsoft Office Access 2003 for Windows: Visual QuickStart Guide. Copyright © 2004 by

Steven Schwartz (Peachpit Press). All rights reserved.
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Key Concepts and Features

The following sections will help familiarize
you with Access’ basic concepts and features.

Tables and datasheets

Regardless of the method used to create an
Access database, the immediate result is at
least one table. A table is a repository for data.
The expression of a table is called a datasheet,
a worksheet-like arrangement of rows and
columns (Figure 2.1). Each row is a single
record and each column is a single field.

If you don’t mind their simple format, you can
use datasheets to perform all common database
activities, such as adding, deleting, and editing
records; sorting; and filtering the data to dis-
play only records that meet your criteria. Adding
and deleting fields, as well as changing a field’s
data type, are also done in the datasheet.

Related tables

Because Access is a relational database, each
table generally stores data on only one topic,
such as address information, delivery services,
or catalog items. To enable you to relate tables
to one another, you create a primary key field
for each table.

A primary key field is one that contains a unique
number for every record. The number can be
assigned by Access whenever a new record is
created. Or if you have an existing unique
numbering system, such as part numbers or
Social Security numbers, you can make that
field the primary key.

Relationships are graphically created and
managed in the Relationships window (Fig-
ure 2.2). A relationship is defined by a pair of
matching fields in two tables. In the main
table, the field is the primary key. In the other
table, it’s an ordinary field referred to as a
foreign key. The names of the matching fields
are unimportant. However, both fields must
contain the same type of data.
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Figure 2.1 This is a typical datasheet. Note the con-
trols for navigating among records.

Figure 2.2 In this two-table dog walker database, the
relationship is the match between the Walker and
WalkerID fields. Every customer has one dog walker,
and every walker can have multiple customers.

Navigation controls

Databases and Projects

In addition to the databases discussed in
this book, you can also create Access
projects. A project provides a means of
interacting with data tables stored on a
Microsoft SQL (Structured Query Language)
server. Projects are not discussed in this
book.
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Custom forms

While you can certainly perform data entry
chores using datasheets, things can occasion-
ally get messy—particularly when a database
involves many tables. To enter an order for a
new customer, for example, you might have to
enter data in several datasheets.

To make data entry easier, Access lets you
create forms (Figure 2.3): layouts that show
only the fields for which you want to gather
data, arranged in an attractive manner. Forms
can also display data from related tables. While
the form backgrounds that Access provides
vary from boring to ugly, you can use your own
patterns or pictures, if you prefer.

Forms can also include subforms. A subform
shows related data from another table or query.
For example, the Northwind sample database
has a Categories form that uses a subform to
show all products for a given category (Figure
2.4). The subform data is taken from the
Products table.

Sorting, filters, and queries

By default, datasheets and forms display all
records in their normal sort order; that is,
arranged in order of the primary key field.
Because this isn’t always the way you’d like to
view the data, you can use Access features to
change the sort order or display only a subset
of records (Figure 2.5).

You can sort by one or several fields in ascend-
ing or descending order. When sorting by
multiple fields, you specify the most important
field first. For example, you might sort an
address table on City, Last Name, and First
Name fields.

To specify a data subset to view, you can apply
a filter (showing only records that contain CA
in the State field, for example) or construct a
complex query containing many criteria. Sort
and filtering instruction are specific to the
database object for which they were created.

Figure 2.3 This simple form is designed to gather
basic employee data. Note that unlike datasheets,
forms can contain special items, such as buttons and
graphics.

Open the Customers form

Figure 2.4 This subform displays all products for the
selected category.

Category Subform data

Figure 2.5 You can create an Advanced Filter/Sort
that includes filtering criteria and sort instructions.
In this example, only records with Wendover as the
City are displayed, sorted by the Last and First fields.

Sorted, filtered datasheet

Sorting and filtering criteria
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Reports

Access reports present and summarize data.
Rather than viewing records one at a time or
in a scrolling list as you’d do with forms or
datasheets, you can display all of your data (or
a selected subset) in an easy to comprehend
fashion (Figure 2.6). You can also specify one
or multiple sort fields, as well as grouping
fields. The latter enable you to automatically
split the data into convenient groups, such as
months (examining purchases over the cur-
rent year, for example) or sales regions.

PivotTables and PivotCharts

Access has some data analysis features not
commonly found in database software. First,
using Microsoft Graph (an integrated compo-
nent of Office), you can create colorful graphs
and charts from selected data. Second, you can
also generate interactive tables (PivotTables)
and charts (PivotCharts). Based on a statisti-
cal function known as a crosstab, PivotTables
(Figure 2.7) and PivotCharts allow you to
view one field broken down by another. For
example, you could create a PivotTable or
PivotChart to show the breakdown of employee
rank by sex. You can also add grouping levels
for more detailed breakdowns.

Data access pages

Any database can be opened for use by one
person (exclusive mode) or multiple users on a
network (shared mode). You can also post a
database on the Internet or a company intra-
net to allow others to access it.

If you want people to be able to view but not
interact with your database, you can export all
or part of a table as a static HTML (Hypertext
Markup Language) page (Figure 2.8) that’s
viewable by anyone with a Web browser. If you
prefer that the data be live and interactive, you
can publish it as a data access page that’s
accessible via a Web browser.
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Figure 2.6 Reports present data in ways that make it
simple to understand and draw conclusions.

Figure 2.8 You can create a static HTML table from
any data table.

Figure 2.7 This PivotTable shows the breakdown of
car expenses by month.
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Wizards

Although you can manually design any table,
form, chart, or report, Access provides tools
called wizards that step you through the pro-
cess. For example, if you’d rather not draw
fields on a blank layout to create a custom
form, the Form Wizard (Figure 2.9) allows
you to select fields from lists and then auto-
matically arranges them in one of several
predefined layouts.

Until you become adept at manually designing
Access objects, it’s a good idea to take advan-
tage of the wizards. Even if the wizard result
isn’t perfect, it’s often easier to edit it than to
create an object from scratch.

Objects, controls, and properties

Every major element in Access is an object—
whether it be a table, form, report, query, data
access page, or macro. The types of objects
that you can create are listed in the Database
window.

Controls are placed within objects. Examples
include fields, list boxes, and option groups for
collecting data. Controls such as these that
have a specific data source are called bound
controls. Static text, lines, and other elements
that are not tied to a data source are called
unbound controls.

Objects and controls all have properties that
you can set or modify. Examples of properties
include Format, Decimal Places, and Width
(for a field on a form); and On Click and Dis-
play When (for a button on a switchboard). To
view or alter the properties of any object and
its controls, open the object in Design View.

✔ Tip

� To modify critical properties of a field
(such as its length or data type), open its
table in Design View (Figure 2.10). This is
also where you create and delete fields.

Figure 2.9 Wizards help you create new objects by
presenting options to you in a series of dialog boxes.

Figure 2.10 Open a table in Design View to examine
or change field properties.
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The Access Interface

The following sections explain the parts of the
Access interface and how to use them.

The Startup Task Pane

When you launch Access from the Start menu,
the Startup Task Pane (Figure 2.11) is the
first thing you see. (Note that if you launch
Access by opening a database, the Startup Task
Pane doesn’t appear.) You can initiate the fol-
lowing tasks by clicking text links in the pane:

� View training materials from Office Online

� Search for help on a topic by entering a
keyword, phrase, or question

� Open a recently used database by clicking
its file name

� Open any other database by clicking More

� Create a new database

After opening a database, the Startup Task
Pane automatically closes. You can also close
the pane manually by clicking its close box.

✔ Tip

� If you’d rather not see the Startup Task
Pane when you launch Access, choose
Tools > Options, click the View tab, and
remove the checkmark from Startup Task
Pane (Figure 2.12).

Figure 2.11 You can open a database, create a new
database, or request help in the Startup Task Pane.

Figure 2.12 You can turn off the automatic display of
the Startup Task Pane.
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The Database window

After you open a database, the most important
component of the Access interface appears:
the Database window (Figure 2.13). Think of
it as Access Command Central. From the Data-
base window, you can open datasheets, forms,
reports, and queries for data entry, viewing, or
design changes.

Down the left side of the window is the Objects
list. Click an object category to list all defined
objects of that type in the right side of the
window. To open a listed item, double-click it.
Other things that you can do in the Database
window include the following:

� Create a new object of the selected type
(Forms or Reports, for example) by clicking
the New toolbar icon or by double-clicking
any of the Create entries in the right-hand
side of the window.

� Delete any database object that’s no longer
needed. Select the object, and either click
the Delete toolbar icon or press d.

� Change the design of any object (adding
fields to a table, changing field data types,
or modifying a form, for example). Select
an object and click the Design toolbar icon.

� Change the name of an object by right-
clicking it and choosing Rename.

✔ Tips

� Closing the Database window is the same
as closing the current database. Leave it
open or minimized until you’re ready to
close the current database.

� Only one database can be open at a time.
Normally, you will close the current data-
base before opening another. If you need to
view multiple databases, you can run mul-
tiple Access sessions by opening additional
databases from the Desktop.

Figure 2.13 Select an object category from the list on
the left and then double-click an object or command
in the list on the right.

Object categories Objects and commands
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Menus and toolbars

Menus and toolbars in Access work as they do
in other Windows applications. For instance,
as you switch from one task to another, Access
automatically displays appropriate menus and
toolbars. There are, however, two differences.

The first difference is that—in order to prevent
new users from being overwhelmed by the
number of commands in each menu—Access
can present abbreviated menus that show only
the commands you’ve recently used (Figure
2.14). The behavior of the Expand indicator at
the bottom of each menu is governed by a
setting on the Options tab of the Customize
dialog box (Figure 2.15).

The second difference is that Access actively
tracks the commands and toolbar elements
that you use. This data is used to continually
modify the menus and toolbars to match your
usage patterns.

✔ Tips

� To change the toolbars that are displayed,
choose Tools > Customize, click the Tool-
bars tab of the Customize dialog box, and
check the toolbars that you want to show.

� In Access, you can customize the standard
toolbars and menus, as well as create new
ones. For instructions, refer to Chapter 20.
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Figure 2.14 To expand an abbreviated menu,
click this Expand indicator or rest the cursor
on it (depending on the settings in the Cus-
tomize dialog box shown in Figure 2.15).

Menu display options

Figure 2.15 You can choose between showing full and
abbreviated menus. With abbreviated menus, you
can also set how they will expand: automatically or
only when clicked.
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Figure 2.16 This text box is always
available for help questions.

Requesting Help

Regardless of where you are in Access at the
moment, there are several ways for you to
request assistance. While you will usually
enter search questions and phrases for Micro-
soft Office Access Help (described below), you
can also do the following:

� In the top section of the Startup Task Pane
(see Figure 2.11), click a tutorial topic.

� To visit Microsoft’s Web site, choose Help >
Microsoft Office Online.

After you’ve begun using the program, you’ll
find that most of the help information is in
Microsoft Office Access Help. Access offers
many ways for you to open and search for
information in Microsoft Office Access Help,
as described in the following lists.

To request assistance from Microsoft
Office Access Help:

1. Do one of the following:

� Open the Access Help pane by choosing
Help > Microsoft Office Access Help,
pressing 1 , or clicking the Microsoft
Office Access Help toolbar icon. Then
type a question or search string in the
Search for text box.

� In the top section of the Startup Task
Pane (see Figure 2.11), enter a search
string in the text box.

� Type a question or search string in the
box at the top of the document window
(Figure 2.16).

� Click the Office Assistant, type a ques-
tion or search string in its text box
(Figure 2.17), and click Search. (If the
Office Assistant isn’t visible, choose
Help > Show the Office Assistant.)

Results are displayed in the Search Results
pane (Figure 2.18).

continues on next page

Figure 2.17 This Office Assistant text box
can also be used to request help.

Figure 2.18 Results of all help searches appear as
entries in this Search Results pane.
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2. Do any of the following:

� To review a result, click the blue text
link. The help text appears in a new
pane (Figure 2.19).

� Click any gray text link that’s preceded
by Help > to open the Table of Contents
to that help entry,

� To go forward or backward through the
pane pages you’ve viewed, click the
arrow icons at the top of the pane.

� To change the help source being
searched (switching from Microsoft
Office Online to Offline Help, for
example), click the down-arrow in the
Search section of the pane, choose the
help material to search, and click the
Start Searching button (Figure 2.20).

3. With the help text displayed (see Figure
2.19), you can do any of the following:

� Click any blue text string to view the
word or phrase’s definition.

� Click any blue topic that’s preceded by
a triangle to show/hide the topic text.

� Click Show All/Hide All to show or
hide all topic text and definitions.

� Click the Print icon at the top of the
pane to print the help text. (Expand
any desired topics or definitions prior
to clicking the Print icon.)

✔ Tip

� To avoid paper waste, you can restrict help
printouts to only selected text. Click and
drag within a help topic to select text, click
the Print icon, and then click the Selection
radio button in the Print Range section of
the Print dialog box.
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Figure 2.19 A clicked Help result appears in this pane.

Figure 2.20 In the Search section of the Search
Results pane, you can select a different source of
help information to search.

Expand all textPrint the topic

Select a help source

Click to execute the searchSearch string


